How to configure your OS to accept ctrl+alt+del

Find help for Frequently Asked Questions here - please look here first before posting an already answered question.

How to configure your OS to accept ctrl+alt+del

Postby redge » 2011-01-05 22:06

If you download zip files with iexplorer on Vista >= and extract the files
direct from the browser they get the downloaded unsecure bit. This cause
ctr-alt-del to fail.
copy from SHARED or/and network folder NTFS fail

internal antivirus check files downloaded to local would also add very annoying security tag to your downloaded files and fail, tested with firefox 4.0 and ie9.0
applicable only for compressed file like .zip or .exe file, not ...setup.exe file.


good
copy from FAT or FAT32 OK
please download to your LOCAL drive and unzip to ultravnc folder on same computer.
or unzip to USB/disk drive FAT32, then copy to your next computer.
Last edited by redge on 2011-01-15 14:49, edited 5 times in total.
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: How to configure uVNC to accept ctrl+alt+del

Postby Rat » 2011-01-09 02:22

I found a solution that works here by setting a Group Policy object to allow services to issue SAS commands...

http://kb.realvnc.com/questions/102/How+can+I+enable+the+%22software+Secure+Attention+Sequence%22+policy%3F

I tested this on Small Business Server 2008 with UltraVNC v1.0.9.5 64-bit

I've quoted this info below in case the original web page "disappears" one day...

There are two ways of setting the needed group policy setting, depending on whether the remote computer is connected to a domain or is a member of a workgroup. Please follow the appropriate section depending on your setup.

Domain procedure (change domain group policy setting)

If the remote computer is connected to a domain, the domain administrator can enable this group policy setting for subdomains or for the entire domain. Please follow these steps:

Important: Only a domain administrator can modify the domain group policy
Important: The domain group policy overrides the local group policy. If the domain group policy is not set, you can use local group policy setting mentioned in the next section.

1. Login to the remote computer as the domain administrator.
2. Click the Start Windows button, select Run, type gpmc.msc and press enter.
3. In the left section, select the desired domain, then right-click and choose Create a GPO in this domain, and link it here.
4. Right-click the new GPO and select Edit.
5. In the left section, please navigate to: Computer Configuration - Administrative Templates - Windows Components - Windows Logon Options
6. In the right section, please double-click on the Disable or enable software Secure Attention Sequence policy and click on Enabled.
7. Set the policy option to Services.
8. Click OK and close the Group Policy Object Editor.

You have now enabled the sending of Ctrl-Alt-Del on all computers that are connected to the domain you selected in step 3.

Workgroup procedure (change local group policy setting)

If the remote computer is a member of a workgroup or is connected to a domain with no domain group policy set, you should follow these steps:

1. Login to the remote computer as a local or domain administrator.
2. Click the Start Windows button, select Run, type gpedit.msc and press enter.
3. In the left section, please navigate to: Computer Configuration - Administrative Templates - Windows Components - Windows Logon Options
4. In the right section, please double-click on the Disable or enable software Secure Attention Sequence policy and click on Enabled.
5. Set the policy option to either Services or Services and Ease of Access applications.
6. Click OK and close the Group Policy Object Editor.

You have now enabled the sending of Ctrl-Alt-Del on the remote computer.
Last edited by Rat on 2011-01-09 02:24, edited 1 time in total.
Rat
80
80
 
Posts: 182
Joined: 2004-11-01 02:11

Re: How to configure uVNC to accept ctrl+alt+del

Postby bolero » 2011-01-15 11:44

I just tried the workgroup solution on non-domain Win 2008 R2 and can confirm that it works. Both methods (vnc button or key combination) work.
bolero
 
Posts: 5
Joined: 2008-03-24 15:50

Re: How to configure your OS to accept ctrl+alt+del

Postby B » 2011-06-22 19:06

FYI, here's a command line that will modify the registry to enable SAS without UAC:

Code: Select all

C:\> reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v SoftwareSASGeneration /t REG_DWORD /d 1 /f



(I'm not sure whether this is necessary or not with the latest UltraVNC versions.)
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: How to configure your OS to accept ctrl+alt+del

Postby luisfernandosm » 2011-08-18 15:43

It works perfect input the registry value... thanks a lot
luisfernandosm
 
Posts: 1
Joined: 2011-08-18 14:53

Re: How to configure your OS to accept ctrl+alt+del

Postby aberu » 2011-11-26 19:03

In my case (from a w7 as client to server W2008 R2 Std. with both having uvnc v1.0.9.6.1) it works now for the sending of Ctrl+Alt+Sup and mouse clicks/mouvement but after that and when the server presents the white box to enter by keyboard the password, it can't be possible. Tried Ctl+V failed too, Tried 'Send Custom Key' and failed also. In that server, I can access remotely by 'Remote Desktop' but not yet by uvn (my prefer one). Any further setup needed?. Thanks.
aberu
 
Posts: 3
Joined: 2011-11-24 19:09

Re: How to configure your OS to accept ctrl+alt+del

Postby B » 2011-12-15 18:01

FAQ Readers, please see also

viewtopic.php?f=9&t=17160

viewtopic.php?f=9&t=16018

Up until version 1.0.9.x, Ctrl-Alt-Del was handled through a separate CAD.EXE module. For most purposes that is no longer necessary, as a software generated "SAS" sequence is now issued directly by UltraVNC via Microsoft system calls.

See the UltraVNC release documentation for more information.
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: How to configure your OS to accept ctrl+alt+del

Postby jennyb » 2012-01-10 22:28

I just tried the workgroup solution on non-domain Win 2008 R2 and can confirm that it works as well.
jennyb
 
Posts: 1
Joined: 2012-01-08 05:57

Re: How to configure your OS to accept ctrl+alt+del

Postby jacobs » 2012-01-26 19:08

jennyb wrote:I just tried the workgroup solution on non-domain Win 2008 R2 and can confirm that it works as well.


I had some issues, is there any way you could help me with this? Send me a private message if possible.

Thanks,
Jacob
jacobs
 
Posts: 1
Joined: 2012-01-26 19:06


Return to FAQ

Who is online

Users browsing this forum: No registered users and 0 guests