MSLogon with special password fails

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

MSLogon with special password fails

Postby Guest » 2004-09-02 07:49

I repeat this topic here because I choosed maybe at first time the wrong forum :(
original will be found here http://sourceforge.net/tracker/index.ph ... p_id=63887
---------------------------------------------------------------------------------------------

I found an anomalie when try to login with MS logon to
a Windows 2000/2003 Server machine.

I'am using RC18 and New MS-Logon (auth.dll from June 25
2004) the password i.e. "Abc0DefG" is not accepted. Any
variation of that pattern fails. I.e. "Hde8TsdZ12345"
and so on. But other Passwords like
"AbCdEfGhIj123456789" are working correct.

The syntax of the password I think it causes the fault is:
- First Letter is uppercase
- Second and third ones are lowercase
- Fourth one must be a numeric value
- next ones are not significant

If I choose a password which have not the above described syntax the connect have no problem.

I think It must be a problem handled with UltraVnc, cause the normal Login to that Windows 2003 Server machine causes no problems.
Guest
 

Postby Marscha » 2004-09-22 09:45

Sorry that it took so long for my reply but I have been on vacation.
I tested some passwords (on W2K) and found the following:
Abc0DefG failed
Bbc0DefG OK
Adc0DefG OK
Abt0DefG OK
Abc0Def OK
Hde8TsdZ12345 OK
So I have only one password failing.
But I agree that this is somehow disturbing.
I'll try to locate the bug and provide a fix :) .
Marscha
Former moderator
Former moderator
 
Posts: 471
Joined: 2004-05-14 06:48

Postby Marscha » 2004-12-10 06:42

Fixed, code is available in cvs, will be included in next RC binary.
Marscha
Former moderator
Former moderator
 
Posts: 471
Joined: 2004-05-14 06:48


Return to MS logon plugin

Who is online

Users browsing this forum: No registered users and 0 guests